Relacyjna baza danych

advertisement
Bazy danych
Obecnie dane najczęściej gromadzi się, przechowuje i przetwarza za pomocą komputera. Dane w postaci
cyfrowej mogą być umieszczone w kilku tabelach, w których dane pozostają w ścisłym związku z sobą. Tego
typu bazy są nazywane relacyjnymi bazami danych.
Na dołączonej do podręcznika płycie CD-ROM, w katalogu Bazy danych, jest umieszczona przykładowa baza
danych Dzienniczek ucznia. Dane w tej bazie są przechowywane w kilku tabelach: Semestr,
Oceny, Kategorie ocen, Przedmioty, Lista ocen. Każda tabela zawiera dane na inny temat. Dane
w tabelach są tak zorganizowane, aby się nie powtarzały. Trzeba też od razu powiedzieć, że
poszczególne tabele nie są obiektami całkowicie od siebie niezależnymi. Taka baza danych byłaby
bardzo niefunkcjonalna. Między tabelami istnieją zatem określone powiązania nazywane
relacjami. Dokładniejsze wyjaśnienie tego pojęcia znajduje się w dalszej części rozdziału. Teraz
wystarczy, że zapamiętasz, że relacja to pozostawanie w związku określonych pól dwóch tabel.
Dzięki temu dane są odpowiednio usystematyzowane. Łatwiejsza też jest praca z taką bazą
danych.
Zanim rozpoczniesz pracę z tą bazą danych, zapisz ją w folderze Mój dzienniczek
na dysku twardym komputera.
Otwieranie gotowej bazy danych w programie
Microsoft Access
Ćwiczenie 1.
Otwórz znajdującą się na płycie CD-ROM bazę Dzienniczek ucznia (folder Bazy danych). W tym celu
wykonaj następujące czynności:
1. Wywołaj polecenie Start/Wszystkie programy/Microsoft Office/Microsoft Office Access 2007.
2. Wciśnij przycisk pakietu Office i wybierz Otwórz
.
3. Wskaż miejsce zapisu pliku bazy danych i kliknij przycisk Otwórz. Możesz też dwukrotnie kliknąć ikonę
Komputer, następnie odpowiednią nazwę dysku, znaleźć folder, w którym została zapisana baza i wreszcie
kliknąć ikonę
.
Po wykonaniu powyższych czynności otworzy się okno Menu bazy danych „Mój dzienniczek”, takie jak na
rysunku 1.
Rysunek 1. Okno Menu bazy danych „Mój dzienniczek”
Uwaga
Otwórz plik Bazy danych Base, znajdujący się na płycie CD-ROM w katalogu OpenOffice, i sprawdź, jak
wygląda okno programu Base. Zapoznaj się z opisami dotyczącymi jego użytkowania.
Warto jeszcze sprawdzić alert zabezpieczeń dla Twojej bazy — czy program nie wyłączył potencjalnie
niebezpiecznej zawartości bazy. W tym celu kliknij przycisk Opcje… i w wyświetlonym oknie zaznacz opcję
(rysunek 2).
Wciśnięcie przycisku
Opcje spowoduje
wyświetlenie okna
Opcje zabezpieczeń
pakietu Microsoft
Office
Rysunek 2. Sprawdzanie w otwartej bazie ostrzeżenia o zabezpieczeniach
Klikając kolejne przyciski w menu, możesz przeglądać informacje oraz dopisywać dane do bazy. Możesz
potraktować dzienniczek jak swój własny i wykonywać różne operacje. Aby jednak możliwe było
wprowadzanie zmian w bazie danych, należy kliknąć opcję Zapisz jako… (rysunek 3), wybrać miejsce
docelowe i zapisać bazę.
Wciśnięcie przycisku
Zapisz jako… umożliwia
zapisanie bazy
Rysunek 3. Widoczna na rysunku opcja Tylko do odczytu informuje, że baza została otwarta tylko do odczytu
Klikając w menu przycisk
, możesz ustalić,
który semestr i który rok nauki będzie aktywny (może być aktywny tylko jeden semestr danego roku). Z kolei
po kliknięciu przycisku Dopisywanie, przegląd i edycja ocen z bieżącego semestru wyświetli się okno
przedstawione na rysunku 4. W tym oknie możesz modyfikować listę przedmiotów. Przyciski w dolnej części
okna służą do nawigacji po ocenach (rekordach) oraz do wykonywania operacji usuwania, dodawania, cofania
i zapisywania rekordów.
Rysunek 4. Okno dopisywania, przeglądania i edycji ocen z bieżącego semestru
Kolejne przyciski w menu umożliwiają:
•
przeglądanie i edycję ocen ze wszystkich semestrów,
•
przeglądanie ocen według przedmiotów,
•
dopisywane i edycję listy przedmiotów,
•
wyszczególnianie najlepszych ocen w bieżącym semestrze,
•
wyszczególnianie średniej ocen z poszczególnych przedmiotów w bieżącym semestrze,
•
wyświetlanie średniej ocen w ciągu wszystkich lat nauki,
•
wyświetlanie średniej ocen ze wszystkich lat według przedmiotów,
•
wyświetlanie raportu z bieżącego semestru,
•
wyświetlanie raportu na temat ocen uzyskanych w ciągu wszystkich lat,
•
przeniesienie ocen z bieżącego semestru do arkusza kalkulacyjnego MS Excel.
Jeżeli klikniesz przycisk
, znajdujący się w prawym dolnym rogu okna, baza danych zostanie
zamknięta. Jeśli użyjesz przycisku
znajdującego się w prawym górnym rogu menu, zostanie zamknięte
menu tej bazy, natomiast samo okno pozostanie otwarte.
Aby zostały wyświetlone obiekty bazy danych, należy — tak jak na rysunku 5. — rozwinąć listę z lewej strony
okna i wybrać na przykład Tabele.
Obiekty bazy danych:
•
tabele
•
kwerendy
•
formularze
•
raporty
•
makra
Rysunek 5. Wybór obiektów bazy danych
Po dokonaniu wyboru wyświetlone zostaną wszystkie tabele utworzone w tej bazie danych. Wystarczy
wówczas podwójne kliknięcie nazwy jednej z nich, aby wyświetlić jej zawartość (rysunek 6).
Przycisk pakietu Office
Wstążka
ułatwiająca szybki
dostęp do
różnorodnych
funkcji programu
Tabele zapisane
w bazie
Pasek tytułu
Przyciski: Minimalizuj,
Maksymalizuj, Zamknij
Karty z
poleceniami
Okno programu
Microsoft
Access 2007
Okno bazy danych
Zawartość tabeli
Kategorie oceny
Pasek stanu
Rysunek 6. Okno tabeli Kategorie oceny
Obiekty bazy danych
Lewa strona okna bazy danych (rysunek 5.) zawiera obiekty bazy, czyli elementy, które wchodzą w jej skład, na
przykład tabele, kwerendy, formularze, raporty. Prawa strona okna służy do wyświetlania zawartości
zaznaczonego obiektu.
Tabele służą do przechowywania danych. Znajdziesz je po rozwinięciu listy obiektów z lewej strony okna bazy
danych. Po kliknięciu opcji Tabele zostaną wyświetlone wszystkie utworzone w danej bazie tabele.
Kwerendy
Kwerendy (ang. queries; niem. die Abfragen) są zapytaniami (sformułowaniami) umożliwiającymi wyświetlanie
pól i rekordów z tabel lub z innych kwerend według kryteriów ustalonych przez użytkownika, a także
porządkowanie danych, wykonywanie obliczeń czy aktualizację danych.
Kwerendy służą do wybierania danych spełniających zadany warunek, łączenia pół, wykonywania obliczeń,
uzupełniania, dołączania lub usuwania rekordów. W jednej bazie danych może istnieć wiele kwerend. Można je
konstruować na podstawie jednej lub wielu tabel i na podstawie innych kwerend.
Formularze
Formularze (ang. form; niem. das Formular) w programie do tworzenia baz danych są obiektami, które
upraszczają proces wprowadzania i aktualizacji danych.
Raport
Raport (ang. report; niem. der Bericht) jest prezentacją wybranych informacji z bazy danych. Raporty
wykonuje się najczęściej w formie wydruku.
Formularze służą do wprowadzania, przeglądania i aktualizowania informacji. Raport to przejrzyste
zestawienie wybranych danych, umożliwiające ich grupowanie i podsumowywanie, przygotowane w celu
wydruku.
Ćwiczenie 2.
Znajdującą się na płycie CD-ROM bazę Dzienniczek ucznia (folder Bazy danych) zapisz na dysku twardym
komputera. Otwórz tabelę Przedmioty (rysunek 7). Dopisz nazwy przedmiotów, których uczysz się w szkole.
Zauważ, że po lewej stronie okna obok pola ID przedmiotu znajduje się znak +, który po kliknięciu można
rozwinąć.
Rysunek 7. Tabela bazy danych
Odpowiedz na pytania:
1. Co to jest baza danych?
2. Jakie obiekty może zawierać baza danych?
3. W jaki sposób otwiera się istniejącą bazę danych?
4. Do czego służą kwerendy, a do czego  formularze i raporty?
Tworzenie nowej bazy danych
Tworzenie tabel
Przed przystąpieniem do tworzenia nowej bazy danych należy określić, w jakim celu jest tworzona baza i jakie
informacje ma przechowywać. Na tej podstawie można ustalić, jakie tabele się tam znajdą oraz jakie informacje
będą one zawierały. Baza może składać się z jednej lub wielu tabel. Każda tabela powinna zawierać informacje
dotyczące tylko jednego tematu, a w kilku różnych tabelach informacje nie powinny się powtarzać.
Tabele w bazie danych można tworzyć za pomocą ułatwiającego pracę kreatora. Inną metodą jest samodzielne
tworzenie tabel w widoku projektu.
Teraz dowiesz się, w jaki sposób utworzono tabelę w bazie Uczniowie (baza znajduje się na płycie CD-ROM w
folderze Bazy danych). Podobną utworzymy w nowym pliku bazy danych i zapiszemy na dysku twardym
komputera. Nowa tabela o nazwie Wypożyczenia książek będzie zawierała następujące pola (kolumny): ID
książki (niepowtarzalny numer przypisany do danej książki), Data wypożyczenia oraz ID osoby.
Tworzenie tabeli za pomocą kreatora
Otwórz pustą bazę danych programu Microsoft Access. W otwartym oknie programu kliknij
i
wpisz nazwę bazy  Uczniowie. Standardowo baza zapisywana jest w folderze Dokumenty, ale jej lokalizację
można zmienić. Wciśnięcie przycisku Utwórz spowoduje wyświetlenie okna jak na rysunku 8.
Rysunek 8. Okno utworzonej bazy danych Uczniowie
, który spowoduje wyświetlenie z prawej strony okna z szablonami pól,
Teraz możesz wcisnąć przycisk
które można wstawiać do tabeli (rysunek 9).
Rysunek 9. Szablony pól, które można wstawić do tabeli
W naszej tabeli powinny się znaleźć pola: ID książki, Data wypożyczenia, ID osoby. Aby wstawić pierwszą
nazwę kolumny, wciśnij prawy przycisk myszy na nagłówku pierwszej kolumny. Z podręcznego menu wybierz
Zmień nazwę kolumny i wpisz ID książki. Następnie w oknie Szablony pól dwukrotnie kliknij jedną z nazw,
na przykład Pojedynczy wiersz tekstu, i zmień ją na Data wypożyczenia. W podobny sposób wstaw nazwę
trzeciej kolumny i nadaj jej nazwę ID osoby.
Po wciśnięciu znajdującego się w lewym górnym rogu okna przycisku Widok projektu
okno, w którym możesz wpisać nazwę tabeli  Wypożyczenia książek.
Twoja tabela powinna wyglądać, jak przedstawiona na rysunku 10.
wyświetli się
Rysunek 10. Utworzona tabela Wypożyczenia książek
Teraz należałoby sprawdzić, czy pola mają nadane właściwe typy danych i w razie potrzeby zmienić na
odpowiednie. W tym celu wykonaj kolejne czynności:
• z list rozwijalnych wybierz dla wprowadzonych nazw pól właściwy typ danych, na przykład dla pola
Data wypożyczenia należy wybrać opcję Data/Godzina (rysunek 11.), a dla ID osoby — opcję
Liczba,
• w dolnej części okna określ format, czyli w przypadku daty wypożyczenia sposób zapisu
wprowadzonej daty (rysunek 12.),
Rysunek 9.11. Określanie typów danych
Rysunek 12. Określanie formatu dla wprowadzonych danych
•
następnie w lewym górnym rogu okna wciśnij przycisk Widok arkusza danych.
Program wyświetli pytanie, czy zapisać tabelę. Po zatwierdzeniu Twoja tabela jest gotowa
do wprowadzania danych (rysunek 13).
Rysunek 13. Utworzona tabela Wypożyczenia książek
W podobny sposób utwórz drugą tabelę, która będzie zawierać następujące pola: ID osoby, Nazwisko, Imię,
Data urodzenia. Dla każdego pola podaj odpowiednie właściwości. Tabelę zapisz pod nazwą Lista uczniów.
Ustalanie relacji między tabelami
Teraz dowiesz się, w jaki sposób można tworzyć zależności między tabelami w bazie danych. Związki między
tabelami w bazie danych są nazywane relacjami.
Związki
Związki (relacje) w bazie danych to zależności między danymi, umieszczonymi w tabelach, umożliwiające ich
logiczne powiązanie z sobą.
W bazie danych mogą wystąpić różne typy relacji między tabelami. Mogą to być relacje typu jeden-do-jednego,
jeden-do-wielu lub wiele-do-wielu. Co to oznacza?
Związek (relacja) typu jeden-do-jednego polega na tym, że jednemu wierszowi (rekordowi) tabeli zostaje
przyporządkowany jeden wiersz innej tabeli. Przykładem może być relacja między przelewem bankowym i
hasłem jednorazowym, gdzie konkretnemu przelewowi ze zbioru (z tabeli) przelewów można przyporządkować
tylko jedno hasło jednorazowe ze zbioru (z tabeli) haseł jednorazowych i odwrotnie — jedno hasło jednorazowe
można wykorzystać tylko do jednego przelewu.
Związek (relacja) typu jeden-do-wielu polega na tym, że jednemu wierszowi (rekordowi) tabeli jest
przyporządkowanych wiele wierszy innej tabeli. Przykładem może być nazwisko wychowawcy klasy
(znajdujące się w jednym wierszu danej tabeli) połączone z wieloma wierszami innej tabeli, gdzie umieszczono
nazwiska uczniów, których ten nauczyciel jest wychowawcą. Z drugiej strony, jednemu wierszowi z drugiej
tabeli odpowiada tylko jeden wiersz z pierwszej tabeli. Oznacza to, że każdy uczeń ma tylko jednego
wychowawcę, ale jeden wychowawca może mieć wielu uczniów.
Związek (relacja) typu wiele-do-wielu
• jeden nauczyciel uczy wielu uczniów, a każdy uczeń ma wielu nauczycieli,
• jedna osoba może wypożyczyć wiele książek, a każda książka może być wypożyczona wiele razy.
Ćwiczenie 3.
W bazie danych Uczniowie utwórz związki (relacje) miedzy tabelami Lista uczniów i Wypożyczenia
książek. Aby tego dokonać, wykonaj następujące czynności:
1. Po otworzeniu bazy Uczniowie wybierz z karty Narzędzia bazy danych polecenie Relacje lub kliknij
przycisk
.
2. W oknie Pokazywanie tabeli zaznacz pierwszą tabelę i kliknij Dodaj. Podobnie należy postąpić z drugą
tabelą, a następnie zamknąć okno.
3. Po dodaniu tabel okno będzie wyglądało jak na rysunku 14.
Rysunek 14. Dodawanie tabel w celu ustalenia relacji
4. Aby między tabelami Lista uczniów i Wypożyczenia książek stworzyć związek (relację) typu jeden-dowielu, która w tym przypadku oznacza, że jeden uczeń może wypożyczyć wiele książek, chwyć myszą pole ID
osoby w jednej tabeli, przeciągnij do drugiej w miejsce ID osoby i upuść. W tym momencie pojawi się okno
Edytowanie relacji (rysunek 15).
Rysunek 15. Okno Edytowanie relacji
Wskazówka
Aby utworzyć relację, tabele muszą być zamknięte.
5. W oknie Edytowanie relacji zaznacz pole wyboru Wymuszaj więzy integralności. Umożliwi to
powiązanie tabel — jeżeli wiersz dotyczący danego ucznia w jednej tabeli zostanie wprowadzony, zmieniony
lub skasowany, automatycznie zmiana ta znajdzie odzwierciedlenie w drugiej. Nie będzie również możliwości
wprowadzenia nowego wiersza do tabeli Wypożyczenia, jeśli rekord ten będzie zawierał wartość ID osoby,
która nie istnieje w tabeli Lista uczniów.
6. Po kliknięciu przycisku OK zostanie utworzony związek (relacja) typu jeden-do-wielu, schematycznie
przedstawiony na rysunku 16.
Rysunek 16. Związek (relacja) typu jeden-do-wielu
Odpowiedz na pytania
1.
Co oznacza pojęcie relacyjna baza danych?
2.
Jakie relacje mogą wystąpić w bazie danych?
3.
Na czym polega relacja jeden-do-wielu?
4.
Do czego służy ikona
?
Prezentowanie danych z bazy za pomocą
formularzy i raportów
Tworzenie formularzy
Formularze służą do wprowadzania danych do tabel oraz do ich aktualizowania. Zanim więc rozpoczniesz
uzupełnianie tabel, musisz przygotować odpowiedni formularz.
Formularze, podobnie jak tabele, można utworzyć samodzielnie w widoku projektu albo posłużyć się kreatorem,
który ułatwi to zadanie (rysunek 17).
Rysunek 17. Opcje umożliwiające tworzenie formularzy
Ćwiczenie 4.
Utwórz formularz do tabeli Wypożyczenia książek, a następnie wprowadź dane dotyczące wypożyczeń. W
tym celu wykonaj następujące czynności:
1. Otwórz bazę Uczniowie, wybierz opcję Kreator formularzy (rysunek 18).
2. W wyświetlonym oknie kreatora przenieś za pomocą przycisku
Dostępne pola:  na listę Zaznaczone pola: (rysunek 18).
kolejne nazwy pól formularza z listy
Rysunek 18. Określanie, które pola mają się znaleźć w utworzonym formularzu
3. Wciśnij przycisk Dalej i zdecyduj, jaki ma być układ formularza.
4. W kolejnym oknie określ jego styl.
5. Po wpisaniu tytułu można kliknąć przycisk Zakończ, aby zakończyć pracę kreatora.
6. Na tym etapie formularz jest gotowy do uzupełnienia (rysunek 19).
Rysunek 19. Gotowy formularz
Do formularza możesz wprowadzać zmiany lub uzupełnić go o inne elementy. Aby zaprezentować
najważniejsze możliwości, posłużymy się przykładem.
Przykład 1.
W utworzonym wcześniej formularzu Wypożyczenia książek zmień tytuł na Wypożyczenia i dodaj wcześniej
przygotowany i zapisany obrazek. W tym celu wykonaj poniższe czynności.
1. Otwórz bazę danych Uczniowie i z dostępnych obiektów wybierz Formularze. Następnie dwukrotnym
kliknięciem otwórz formularz Wypożyczenia książek.
2. Aby rozpocząć wprowadzanie zmian w formularzu, wybierz opcję Widok projektu (rysunek 20).
Rysunek 20. Okno wyboru widoku Formularza
Wskazówka
Jeśli w Twojej bazie danych wyświetla się Ostrzeżenie o zabezpieczeniach mówiące, że określona
zawartość bazy danych została wyłączona, kliknij przycisk Opcje i zaznacz opcję
.
3. Wyświetlone okno będzie wyglądało tak, jak na rysunku 21. Zwróć uwagę, że w górnej części okna zostały
uaktywnione narzędzia projektowania.
Rysunek 21. Wygląd formularza w widoku projektu
4. W chwili kliknięcia nagłówka formularza zostaje uaktywniony kursor umożliwiający zmianę tytułu.
5. Zmień tytuł na Wypożyczenia. Za pomocą narzędzi formatowania podobnych do tych w edytorze tekstu
wyśrodkuj tytuł i zmień jego kolor.
6. Następnie wklej element graficzny. Tę czynność umożliwi Ci kliknięcie ikony
.
7. W wyświetlonym oknie wskaż miejsce zapisu pliku graficznego, który ma zostać wklejony.
8. Podwójne kliknięcie wybranego pliku graficznego spowoduje, że zostanie on wstawiony do formularza.
Element graficzny możesz przenieść w dowolne miejsce formularza.
9. Pamiętaj o dopisaniu zmian do formularza.
Ćwiczenie 5.
Otwórz formularz Wypożyczenia i wprowadź dane do kolejnych 10 wierszy. Podczas wpisywania korzystaj z
przycisków nawigacyjnych (posługiwanie się przyciskami omówiono w podrozdziale 9.2 podręcznika).
Raporty
Raport służy do prezentacji danych na wydruku. Projektując raport, masz możliwość ustalenia jego wyglądu
przez wybór odpowiednich opcji. Informacje w raportach mogą być grupowane lub porządkowane według
określonego kryterium. Szybkim sposobem tworzenia raportów jest — podobnie jak w przypadku formularzy —
użycie kreatora raportów. Aby zapoznać Cię ze sposobem tworzenia raportów, posłużymy się przykładem.
Przykład 2.
Za pomocą kreatora utwórz raport do tabeli Lista uczniów zawierający identyfikatory osób, ich nazwiska i
imiona. W tym celu wykonaj następujące czynności:
1. Otwórz bazę danych Uczniowie.
2. Na karcie Tworzenie wybierz
.
3. W oknie Kreator raportów określ tabelę (lub kwerendę) źródłową, z której będą pobierane dane. W
naszym przykładzie jest to Lista uczniów (rysunek 22).
4. Następnie z listy dostępnych pól wybierz te, które mają się znaleźć w raporcie, i przemieść je na listę
Zaznaczone pola (zaznaczając je i wciskając pojedynczą strzałkę).
Rysunek 22. Okno Kreator raportów
5. Klikając przycisk Dalej, będziesz przechodzić do kolejnych okien kreatora, w których określisz, czy rekordy
mają być sortowane (dla jakich pól i w jakim porządku), jaki ma być układ raportu (kolumnowy, tabelaryczny,
wyjustowany), jaką przyjąć orientację strony (poziomą czy pionową), jaka ma być szata graficzna raportu (styl)
i tytuł.
6. Po kliknięciu przycisku Zakończ zostanie wyświetlony gotowy raport.
Raport, podobnie jak formularz, można wzbogacić o nowe elementy: tytuł, nowe pola, obrazki, przyciski.
Zmiany i aktualizacje w raporcie przeprowadza się w widoku projektu w podobny sposób, jak w przypadku
formularza.
Czy wiesz, że w pewnych sytuacjach utworzenie raportu nie będzie możliwe? Jeśli w systemie nie ma
zainstalowanej drukarki, pojawia się komunikat o konieczności zainstalowania sterowników drukarki.
Dopiero wtedy można kontynuować tworzenie raportu.
Korzystając z przygotowanej na płycie CD-ROM bazy danych Dzienniczek ucznia, wykonaj
następujące ćwiczenia:
Ćwiczenie 6.
Otwórz raport Raport — wszystkie oceny w bieżącym semestrze. W widoku projektu usuń rekordy
dotyczące roku i semestru. Zapisz raport pod nazwą Bieżący semestr — oceny.
Ćwiczenie 7.
Otwórz formularz – Oceny z poszczególnych przedmiotów. Wprowadź trzy nowe rekordy, a następnie
uzupełnij je danymi.
Odpowiedz na pytania
1.
W jakim celu tworzy się formularze do bazy danych?
2.
Jak utworzyć raport do bazy danych?
Download
Random flashcards
123

2 Cards oauth2_google_0a87d737-559d-4799-9194-d76e8d2e5390

ALICJA

4 Cards oauth2_google_3d22cb2e-d639-45de-a1f9-1584cfd7eea2

Motywacja w zzl

3 Cards ypy

66+6+6+

2 Cards basiek49

słowka

2 Cards kksenia.kot1997

Create flashcards