Excel na lekcjach matematyki

advertisement
dr Joanna Kandzia
Nauczanie matematyki przez doświadczenia i eksperymenty, wykorzystanie TIK podczas
zajęć dydaktycznych
Excel na lekcjach matematyki
Posługiwanie się komputerem i technologią informacyjną na lekcjach matematyki stwarza nowe
możliwości realizacji i kształtowania tradycyjnych treści i umiejętności.
Komputer na lekcjach matematyki spełnia dwie podstawowe funkcje: urządzenie wspomagające
proces uczenia się (pomoc dydaktyczna) oraz urządzenie łącznie z metodami informatyki do
wzbogacania i rozszerzania zakresu i metod matematyki (element składowy). Jeżeli użyjemy
programu do analizy wykresu funkcji, to skorzystamy jedynie z pomocy sprzętowej. Jeżeli użyjemy
arkusza kalkulacyjnego do realnych działań, to można mówić o operacjach matematycznych
zintegrowanych z narzędziami technologii informacyjnej. W każdym z przypadków występują
zadania matematyczne oraz elementy posługiwania się komputerem. Wykres funkcji uczeń może
przeanalizować niezależnie od sprzętu, wykorzystując swoją wiedzę matematyczną. W przypadku
obliczeń komputer jest integralną częścią operacji matematycznych.
W społeczeństwie wiedzy, interdyscyplinarność kształcenia wymusza na nauczycielach
matematyki wykorzystywanie narzędzi technologii informacyjnej. Bez niej współczesna
matematyka nie mogłaby osiągać takiego postępu. Należy wspomnieć o problemach
matematycznych dla których istnieją jedynie dowody komputerowe. Problem czterech barw,
rozstrzygnięty przez K. Appela i W. Hakena z istotną pomocą informatyka J. Kocha z
wykorzystaniem komputera IBM. Czy też rozwiązanie 100 letniego problemu matematycznego,
kompletny opis grupy E8 (grupa Liego - gładka rozmaitość), w marcu 2007, co domknęło
klasyfikację prostych grup skończonych. Współczesny uczeń musi być przygotowany do
funkcjonowania w realnym świecie. Zadaniem nauczyciela, w tym wypadku nauczyciela
matematyki jest wskazanie odpowiednich narzędzi i ich możliwości.
Zaproponowana lekcja matematyki z wykorzystaniem Excela może stanowić dodatkową
pomoc dydaktyczną dla nauczycieli matematyki i informatyki. Zachęcić do stosowania tego
narzędzia na lekcjach. Posłużyć do sprawdzenia poprawności rozwiązań uzyskanych metodą
tradycyjną. Uczniowie mogą poszerzyć swoją wiedzę matematyczną w kierunku wykorzystania
technik komputerowych. Wymagania zarówno dla nauczycieli i uczniów sprowadzają się do
podstawowej znajomości Excela. Zadanie jest wykonalne w ciągu jednej godziny lekcyjnej.
Moduł 1
Temat: Liczba doskonała
Sprawdzamy czy dana liczba naturalna jest liczbą doskonałą.
Liczba doskonała, to taka liczba, której suma wartości wszystkich jej dzielników właściwych
równa się jej samej.
Sposób rozwiązania:
1. Rozmieszczenie w arkuszu stałych elementów tekstowych.
2. Przygotowanie arkusza do sprawdzania, czy dana liczba z przedziału od 1 do 1000 jest
liczbą doskonałą.
3. Sprawdzenie czy każda z tych liczb jest dzielnikiem podanej liczby – wykorzystanie funkcji
MOD()). Sprawdzanie dla liczb większych od badanej liczby nie jest konieczne, nie mniej
nie spowoduje to błędu.
4. Zliczenie liczby odnalezionych dzielników i podanie wartości ich sumy – wykorzystanie
funkcji SUMA() oraz ILE.LICZB()).
Rozwiązanie:
Rozmieszczenie w arkuszu elementów tekstowych (pomijamy wypełnione tłem) – rysunek 1.
1. Przygotowanie kolumny z ciągiem liczb od 1 do 1000. Do komórki A1 wpisujemy 1 i
kolejne komórki aż do A1000 wypełniamy liczbami kończąc na 1000.
2. Przygotowanie drugiej kolumny, do sprawdzania, czy odpowiadająca jej liczba z kolumny A
jest dzielnikiem podanej liczby n.
3. Do komórki B1 wpisujemy: B1: =JEŻELI((MOD(F$6;A1)=0);A1;" ").
4. Formułę kopiujemy aż do komórki B1000.
5. Wyznaczenie, ile powstało dzielników w kolumnie B oraz ile wynosi suma ich wartości.
6. Do komórek G11 i G12 wpisujemy:
7. G11: =ILE.LICZB(B1:B1000), G12: =SUMA(B1:B1000)-F6
8. Wyświetlenie komunikatu, podającego wynik obliczeń.
9. Do komórki D15 wpisujemy: D15: =JEŻELI(F6<>G12; "Liczba NIE jest Liczbą
doskonałą!";"Liczba JEST Liczbą doskonałą!").
10. Kolumny A i B można ukryć.
Rysunek 1. Przykład liczby, która nie jest doskonała
Źródło: opracowanie własne
Rysunek 2. Przykład liczby doskonałej
Źródło: opracowanie własne
Przygotowanie samego arkusza jest dość pracochłonne, jednak raz tak skonstruowane narzędzie
pozwala badać w krótkim czasie dowolne liczby.
Moduł 2
Temat: Najmniejsza wspólna wielokrotność, największy wspólny dzielnik
Wyznaczamy NWW i NWD oraz sprawdzamy czy badane liczby mieszczą się w zadanym
przedziale liczbowym.
NWW to najmniejsza liczba, przez którą dzielą się badane liczby, zaś NWD to największa
liczba spośród wszystkich dzielników obu liczb.
Sposób rozwiązania:
1. Przygotowanie arkusza do wyznaczenia NWW i NWD dowolnych dwóch liczb naturalnych
z przedziału od 2 do 1000.
2. Wykorzystanie funkcji logicznych LCM() i GCD().
3. Warunek na zakres danych zostanie sprawdzony funkcjami JEŻELI() i LUB().
Rozwiązanie:
1. Rozmieszczenie w arkuszu elementów tekstowych (pomijamy wypełnione tłem) – rysunek.
2. Określenie formuły badającej spełnienie warunku z zakresu danych.
3. Do komórki B8 wpisujemy: B9 =JEŻELI(LUB(C7>1000;E7>1000;C7<2;E7<2);”KTÓRAŚ
Z LICZB (LUB OBIE) NIE SPEŁNIA WARUNKÓW !”; „LICZBY SPEŁNIAJĄ
PRZYJĘTE ZAŁOŻENIA”)
4. Wyznaczenie NWW
D12: =NAJM.WSP.WIEL(C7;E7)
5. Wyznaczenie NWD.
D14: =NAJW.WSP.DZIEL(C7;E7)
Rysunek 3. Przykład wyznaczania NWW, NWD
Źródło: opracowanie własne
Moduł 3
Temat: Układ dwóch równań liniowych - Metoda wyznaczników (Cramera).
Dany jest układ dwóch równań liniowych:
a1x + b1y = c1
a2x + b2y = c2
Sposób rozwiązania:
1. Przygotowanie arkusza do rozwiązania (metodą wyznaczników) dowolnego układu równań.
2. Rozmieszczenie w arkuszu stałych elementów tekstowych.
3. Wykorzystanie funkcji JEŻELI() oraz funkcji JEŻELI() podwójnie zagnieżdżonej w części
dotyczącej rozwiązania układu równań.
Rozwiązanie:
1. Rozmieszczenie w arkuszu elementów tekstowych (pomijamy wypełnione tłem) - rysunek.
2. Zdefiniowanie formuły określającej, czy układ ma rozwiązanie.
Do komórki D14 wpisujemy: D14: =JEŻELI((C8*E9-C9*E8)<>0;"Układ jest
niezależny";JEŻELI(E8*G9-E9*G8=0;"Układ jest zależny";"Układ jest sprzeczny")).
3. Wyznaczenie wartości niewiadomej x układu.
Do komórki C19 wpisujemy: C19: =JEŻELI(D14="Układ jest niezależny";(G8*E9G9*E8)/(C8*E9-C9*E8);"Brak rozwiązania").
4. Wyznaczenie wartości niewiadomej y układu.
Do komórki F19 wpisujemy: F19: =JEŻELI(D14="Układ jest niezależny";(C8*G9C9*G8)/(C8*E9-C9*E8);"Brak rozwiązania").
Rysunek 4. Przykład układu niezależnego
Źródło: opracowanie własne
Rysunek 5. Przykład układu sprzecznego
Źródło: opracowanie własne
Rysunek 6. Przykład układu zależnego
Źródło: opracowanie własne
Literatura
Obecny A., Matematyka w Excelu dla szkół średnich, Kraków, Helion 2001
Sysło M. M., Komputery, Informatyka i Technologia Informacyjna w nauczaniu matematyki,
www.dlaszkoly.pl/mik/num/mik1/mik2_4.htm
www.excelszkolenie.pl
Download
Random flashcards
ALICJA

4 Cards oauth2_google_3d22cb2e-d639-45de-a1f9-1584cfd7eea2

bvbzbx

2 Cards oauth2_google_e1804830-50f6-410f-8885-745c7a100970

Create flashcards